Status
Back
Maintenance
Moving over the servers.
Completed 13 Jul at 11:36pm EDT.
Affected services
api.rankblox.xyz
Completed
Maintenance completed
Posted 13 Jul at 11:36pm EDT.
Started
The bot will be down as I move it over.
Posted 13 Jul at 11:30pm EDT.